EasySim
Educational Digital Simulator for Windows™

User's Guide
CONTENTS

INTRODUCTION ................................ ................................ ................................ .... 1
EasySim features ................................ ................................ .................................... 1
Hardware and software requirements ................................ .............................. 2
How to contact Research Systems ................................ ..................................... 2

CHAPTER 1 Getting Started ................................ ................................ .................. 3
Installing EasySim ................................ ................................ ..................................... 3
Starting EasySim ................................ ................................ ......................................... 4
Exiting from EasySim ................................ ................................ .................................. 5
Accessing Help ................................ ................................ ........................................... 6
General Help ............................................................................................................ 6
Context Sensitive Help ............................................................................................ 6

CHAPTER 2 EasySim Basics ................................ ................................ ................. 7
The User Interface ................................ ................................ ....................................... 7
Making connections ................................................................................................. 7

CHAPTER 3 Working with Circuit Files ................................ ................................ . 8
Creating a new circuit ............................................................................................... 8
Opening an existing circuit ....................................................................................... 8
Saving circuit files ..................................................................................................... 10
File Save .......... File Save As .................................................................................. 10
Printing a circuit design .......................................................................................... 11
File Print .................................................................................................................. 11
File Printer Setup .................................................................................................... 12

CHAPTER 4 On Screen Editing ................................ ................................ ............... 15
Edit Delete ............................................................................................................... 15
Edit Rotate ............................................................................................................... 16
Edit Move ................................................................................................................ 16

CHAPTER 5 EasySim Connections ................................ ................................ ....... 17
Design versus Simulation ......................................................................................... 17
Good Connections ................................................................................................... 17
Applying Power ........................................................................................................ 18
Correct wiring ............................................................................................................ 19
Placing Wires ............................................................................................................ 19
Joining Wires ............................................................................................................ 20
Other Connections ................................................................................................... 20
Design Rule Checks ................................................................................................. 20
Open Inputs ............................................................................................................... 21

CHAPTER 6 EasySim Logic Blocks ................................ ................................ .......... 23
Logic Sources .......................................................................................................... 23
**INTRODUCTION**

*EasySim* is a sophisticated software tool that integrates the process of designing and simulating the operation of digital electronic circuitry.

Written primarily with the Australian Year 11 Physics Syllabus in mind *EasySim* will find practical use in all areas of electronics education worldwide. *EasySim* will also be of great value to the aspiring electronics enthusiast and to the small electronics business alike.

Designed to run under Windows 3.0 or later, *EasySim* presents an easy way to learn, or to enhance knowledge of, the operation of digital electronics at the logic gate level.

*EasySim features*

*EasySim* provides everything that you need to design and simulate the operation of digital electronic circuits.

Features include:-

- Graphics-oriented circuit editor, helping to make an easy task of circuit design.
- On screen, real time, display of logic levels, giving a visual representation of actual circuit operation.
- Built in library of common logic blocks, including D type and JK flip flops.
- Online context sensitive help.
- Simulated visual indicators including lamps and hexadecimal displays.
- A selection of logic level sources including constant high and low levels and toggle switches.
- Automatic break-out from unstable or self-oscillating circuit designs.
- A self scaling print option that scales the *EasySim* design area to fit the currently selected printer.
- Circuit file load and save facilities.
Hardware and software requirements

The following are the minimum requirements for using EasySim:

- You must have a computer capable of running Windows in either standard or 386 enhanced mode (80286 processor or better). There must be at least 2MB of RAM available on the computer and it must be equipped with a graphics display of VGA or better. A mouse or other pointing device will also be required.
- You must have Windows 3.0 or later installed on your computer (i.e Windows 3.0, 3.1 or Windows NT).
- You must have at least 400KB of free disk space for EasySim and its associated files.

How to contact Research Systems

Should you have any comments or problems concerning the operation of EasySim, Research Systems may be contacted by writing to the following address:

Research Systems Pty. Ltd.
15/1540 Main Road,
Research,
Victoria 3095
Australia

For technical support we will require the following information:

1. Product details, including name, version, serial number and licence type. These are all available from the About option within the Help menu.
2. Computer model and setup.
3. Windows version number.
4. Name and address of licensee.
5. Date of purchase.
CHAPTER 1

GETTING STARTED

This section provides information on how to install *EasySim* and covers the basics for starting, exiting and using the context sensitive help in *EasySim*.

**Installing EasySim**

The following procedure is required to install *EasySim* from DOS. The assumption is made that the Windows directory is already set in the DOS PATH variable.

1. Insert the *EasySim* distribution diskette in an appropriate drive. We will use drive 'B' for the sake of this example.
2. From the DOS prompt (i.e. before starting windows) select the drive by typing `B:` followed by the ENTER key.
3. Type `WIN SETUP` followed by the ENTER key at the DOS prompt.
4. Windows will now run and install the *EasySim* software on your hard disk.
5. After installation a new program group will appear in the program manager window containing an icon for *EasySim*.

To install from within Windows follow this alternate procedure:

1. Insert the diskette as in 1 above.
2. Select the RUN option from the FILE menu.
3. Using the BROWSE option from the dialogue box select SETUP.EXE on the *EasySim* distribution diskette.
4. Select the OK button of the dialogue box.
5. *EasySim* will now be installed as above.

In both cases an initial dialogue box will be displayed before installation proceeds. This will give the option of using the default
directory for installation or of choosing where the *EasySim* files should go.

If it is desired to proceed with the default installation then click on the OK button. If another directory is required then modify the directory name in the dialogue box.

If, however, it is desired that installation be completely aborted click on the CANCEL button. This will stop the installation of *EasySim* from being performed.

**Starting *EasySim***

Once *EasySim* has been installed it will appear as an icon labelled Logic Simulator in the newly created program group of the same name.

To start *EasySim* double click on the Logic Simulator icon. This will bring up the *EasySim* main window with menu bar and toolbox.
The File menu may be used to create a new design, to load an existing design or to save either a new or a modified design.

**Exiting from EasySim**

There are a variety of methods to exit from EasySim:

1. Select the Exit option from the File menu.
2. Double click the Control-menu icon at the top left corner of the EasySim window.
3. Hold down the ALT key and press the F4 function key.

If you have made any changes to the circuit since the last time it was saved you will be asked whether you want to save the circuit before quitting.

EasySim will prompt you to save your file if has been modified in any way.
Accessing Help

Help may be accessed in EasySim just as in any other Windows application.

EasySim gives access to context sensitive help as well as to general help information.

General Help

This may be accessed by choosing the Help option from the Help menu.

Using this method puts you into a two page help screen that will take you to either menu information or to toolbox information depending on the page selected.

If you require help on a given subject use the Search option of the Help screen to search for an appropriate key word.

Context Sensitive Help

Context sensitive help is accessed by pressing the F1 key whilst a menu selection is highlighted.

Help information displayed in this fashion will be relevant to the menu item selected.

To highlight a menu option without selecting it use the following steps:

1. Select the main menu heading by means of the mouse or appropriate key combination.
2. Select the sub menu option by means of the up or down cursor keys.

Once a menu option is highlighted pressing ENTER will select it whereas pressing F1 will select the help information for that option.

Help runs as a separate application under Windows. As such it is possible to leave Help running and return to EasySim.

Alternatively Help may be terminated by pressing the ALT and F4 keys simultaneously, by selecting the Exit option of the File menu or by double-clicking on the Control-menu box.
CHAPTER 2

EasySim Basics

The User Interface

EasySim makes extensive use of the standard Windows menu and mouse type of user interface.

As an extra to this EasySim has a comprehensive toolbox (pictured left) that allows fast access to frequently used menu options. This toolbox may be moved around the screen by dragging on its title bar with the mouse.

As well as making standard use of the left mouse button EasySim also utilises the right one. This is used to escape from the last activity and returns EasySim to its default line drawing mode. It is this mode that allows simulated electrical interconnections to be made between logic blocks.

Should EasySim already be in line editing mode, however, pressing the right hand mouse button will release any 'rubber banding' that may exist on the screen at that time.

Making connections

For EasySim to operate correctly as a logic simulator, as well as circuit design tool, it is very important that interconnections are correctly made. In order to make suitable contact the lines, or wires, must be touching (end to end) or run into the logic block connecting points. To assist in this the edit cursor always 'snaps' to a background grid that is aligned with the connection points of all logic blocks.

An exception to this are the wires themselves. In order to join two wires one must butt up precisely against the other.

Alternatively where two wires cross, or where two or more wires meet, placing a junction at that point will ensure that correct connection is made.
CHAPTER 3

Working with Circuit Files

This chapter describes how to load, save, name and print EasySim circuit files.

All operations in this category are controlled by the File menu.

By convention all EasySim circuit files are suffixed with ".SIM" to distinguish them from files of other types.

Creating a new circuit

To create a new circuit file select the New option from the File menu. This will clear any previous circuit design from the screen after prompting you to save it should it have been modified in any way.

Once the screen has been cleared you may begin to edit a new circuit. The file name of a new design will default to "UNTITLED.SIM" although you will be prompted to change this the first time you save the file.

Opening an existing circuit

An existing circuit may be one saved earlier by EasySim or one of the supplied sample files.

To open an existing file choose the Open option from the File menu. This will display the Open File dialogue box.
Chapter 3  Working with Circuit Files

To specify the file name follow either one of the following procedures:

1. Type the file name and then press the Enter key.
   - If you type in a file name you must also specify its full path if it does not exist in the current directory. For example you might type C:\EASYSIM\COUNT16.SIM.

2. Choose a file from the Files list.
   - You may change directories from within the Open File dialogue box by selecting required drive and directory from the Directories list adjacent to the Files list.

When loaded a circuit is put in a state that is ready for simulation and with logic tracing enabled by default.

This means that the circuit is in "Power On" mode and that any switches on the circuit may be operated by clicking the mouse on them. As logic tracing is enabled any change of logic levels in the circuit will be made visible by alterations of intensity on the connecting wires.

Normal edit mode may be entered by clicking the right mouse button or by making a toolbox or menu selection.
Saving circuit files

It is advisable to save your work fairly often and at least before you exit from EasySim, create a new file or load an existing file.

EasySim provides two methods for saving circuit files, the normal Save option and the Save As option.

File Save

Choose the Save option from the File menu in order to save a circuit file. If the circuit file has been recently created with the New option from the File menu a dialogue box will be displayed. This allows the file name to be specified.

File Save As

Choose the Save As option from the File menu if it is required to save the circuit file under a new name, or when saving a new design.

Selecting this option causes a dialogue box to be displayed in which the new file name may be entered. This dialogue box is also displayed, by default, when saving a new design for the first time.

The File Save As dialogue box.
Printing a circuit design

In order for EasySim to provide a hard copy of a circuit design, facilities are included for both setting up a printer and for design printing.

File Print

EasySim makes easy work of printing your design.

The current design may be printed at any time by selecting the Print option from the File menu.

EasySim has an intelligent printing algorithm that automatically scales its drawing area to that of the currently selected printer.

It does not matter what type of printer is connected, if it can support graphics it will be able to print an EasySim circuit

The drawing area within EasySim is 1840 by 1380 pixels and has a 4:3 aspect ratio. To give an example of scale most EasySim logic gates are 50 by 30 pixels in size.

The 4:3 aspect ratio of EasySim allows excellent mapping to most common printer paper sizes. For best results, however, ensure that you printer is set up in Landscape and not in Portrait mode.
File Printer Setup

*EasySim* has a facility for setting up a printer, separately from the main Windows setup.

Select the required printer from the 'Select Printer' dialogue box.

Having selected the required printer you may now configure it from the setup dialogue box. The dialogue box will hold differing information depending on the printer selected.

Your Windows documentation will provide further information on setting up printers.
CHAPTER 4

On Screen Editing

This chapter describes how to access and use the screen editing facilities available within EasySim.

EasySim allows you to delete, move or rotate onscreen items as well as being able to change the default orientation for the placement of logic gates.

All of the editing facilities are accessible from either the Edit menu or from the toolbox.

Selecting any of the Edit options will change the mode of the cursor to the option selected.

Edit Delete

The Delete Tool

Any items placed in the EasySim edit screen may be deleted if no longer required.

To do this we must first set the cursor into delete mode. This is achieved by either selecting the Delete option from the Edit menu or by clicking the left mouse button whilst the cursor is over the button in the toolbox.

The cursor will then be in delete mode.

To delete any onscreen item the cursor must be moved over that item and the left mouse button clicked. This process will remove the item under the cursor, or the first placed item under the cursor in the case of multiple objects existing under it.

Sometimes 'bits' or fragments of items may be left on the screen after being deleted. This is an inescapable characteristic of the screen mode used for drawing.

To 'clean up' the screen after deleting items select the Redraw option from the Options menu.
**Edit Rotate**

The Rotate Tool

Most items that can be placed in the *EasySim* edit screen are capable of two orientations, either left or right facing. By default, logic gates, when selected, will have their inputs on the left and their outputs on the right. It may not always be convenient to place the gates in this manner so *EasySim* provides a rotate tool in order to flip the horizontal orientation of the gates.

In order to rotate an existing gate select either the Edit Rotate menu option or click on the button of the toolbox. This will place the cursor into rotate mode. Now move the cursor over any item that you wish to rotate and click the left mouse button. The item under the cursor will, if it is rotatable, then change its orientation. Repeated clicking of the left mouse button over an item will continually change the item orientation.

*EasySim* always remembers the last selected orientation and uses this as the default for new selections. If you know that the current orientation is not what you require, click the mouse on the button before selecting the next item to place on the screen.

As with most modes of operation clicking the right mouse button will return the cursor to line drawing mode.

---

**Edit Move**

The Move Tool

All items in the *EasySim* edit screen may be moved to another position within the current window.

To do this we must first set the cursor into move mode. This is achieved by either selecting the Move option from the Edit menu or by clicking the left mouse button whilst the cursor is over the button in the toolbox.

The cursor will then be in move mode.

To move any on screen item, the cursor should be moved over that item and the left mouse button held down. The item selected will change to a white outline and will now move around the screen as the mouse is moved. When the item is at the location that you wish to place it just release the left mouse button. The item will revert to its normal colour when released.

To revert to line drawing mode just click the right mouse button.
CHAPTER 5


EasySim Connections

This chapter revisits, in more detail, the methods of connecting the various logic blocks together.

Design versus Simulation

First we will look at the need for correct connectivity in order for circuit simulations to function correctly.

Good Connections

As previously mentioned, in chapter 2, it is important that connections are correctly made in order that the simulation feature of EasySim will function correctly.

If EasySim were just to be used as a design tool it would not matter that connections were incorrect, as long as the circuit 'looked' right. EasySim, however, requires that connections be correctly made, in order for circuit simulation to function correctly.

It is quite possible, within EasySim to overlay and cross wires without an electrical connection being made between them. This is sometimes undesirable when it comes to simulating the circuit design. Where wires have been overlapped instead of joined there will be no continuity of logic level flow between these wires.

If it does happen that some connections are not made correctly your circuit design may not function quite as expected. If you suspect that you may have this problem turn on the Logic Trace option in the Options menu. This will then activate the wire highlighting mode of operation. Any wire carrying a logic one level will be displayed in light green. Conversely, wires carrying a logic low level will stay displayed as dark green. If any wire is light green for part of its length and dark green for the rest a problem exists. In this case it is probably better to delete the wire and run a new one.
Applying Power

The major difference between a design tool and a simulator is that the simulator has the ability to apply 'power' to a circuit to see how it performs.

A major feature of EasySim is that it allows simulation of applied power to a circuit design. When in power on mode the cursor may be placed over a switch and the left mouse button clicked. This will then toggle the state of the switch and the change in logic levels so caused will propagate throughout the entire circuit, whilst correctly simulating the circuit operation.

Power on mode is entered by selecting the Power On option in the Power menu or by clicking the left mouse button whilst the cursor is over the POWER button of the toolbox.

In powered up mode it is possible to keep track of the logic levels in the circuit by making use of the Logic Tracing option of the Options menu. This will highlight all wires carrying a logic high level.

Clicking on the right mouse button will revert EasySim to its line drawing mode. Other options may be selected as usual.

Occasionally it may be that an unstable or self oscillating circuit is being powered up. This will result in a continuous change in logic levels that will never be able to stabilise.

In this case EasySim will stop the simulation (after about 50 iterations) and display a warning message. Note that the displayed logic levels may not be correct when this happens.

EasySim will recognise unstable circuits. Alter the circuit, if required, to avoid the problem recurring.
Correct wiring

As discussed in the previous section it is important that wires are correctly positioned for simulation to be effective.

*EasySim* has a slightly unusual wiring method. It does not, however, take long to learn and it allows a neat circuit design to be drawn with very little practice.

### Placing Wires

Line drawing mode is the default mode of *EasySim* and may be entered by various methods.

1. Click the right hand mouse button at any time other than when running a wire.
2. Select the Wire option from the Routing menu.
3. Select the from the toolbox.

To place the first point of the wire click the left mouse button at the required place. Then, as the mouse is moved, a rubber band 'wire' can be dragged around the screen. This wire will only place itself along horizontal and vertical axes and may split into two segments as the mouse is moved. These segments will automatically adjust themselves to the current position of the mouse, such that there is one horizontal and/or one vertical segment.

Clicking the left mouse button will 'drop' the first segment of the wire and further movement of the mouse will again rubber band two active segments. When the mouse is over the place where it is desired to terminate the wire the left button must be clicked either once or twice depending on the number of active segments still tracking the mouse. If only one segment is active then click the mouse button once, if two segments are active then click it twice.

At any time the active rubber banding segments may be discarded by clicking on the right mouse button.
Joining Wires

Wires that cross each other may be electrically joined by means of junctions. Two wires that meet each other on the same plane, either horizontally or vertically, may be joined by simply butting up against, but not overlapping, each other.

Alternatively a vertical wire may be joined to a horizontal wire if one end of each butt up against each other.

To select a junction either select the Junction option from the Routing menu or click the left mouse button whilst the cursor is over the button in the toolbox.

Whilst EasySim is in junction mode the cursor will drag with it the junction. This junction may the be placed at any required spot by clicking the left mouse button. At this time the junction will be dropped and EasySim will revert to line drawing mode.

A junction is a necessary item to electrically connect two wires that cross at any point. It is important that the junction be placed exactly on the crossing point to be effective. Once again the logic tracing function may be used to confirm correct connectivity.

An important point to remember is that two wires may cross with no electrical connection existing between them. If you want a connection to take place then place a junction on the intersect.

Other Connections

EasySim allows for some degree of inaccuracy when wiring to all other items, gates, switches, displays etc.

All these items allow a connection overlap of from 0 to 10 pixels into their connection points. EasySim itself simplifies the wiring by 'snapping' to a 5 pixel grid. This facilitates all editing operations within EasySim and helps to prevent items or wires from being misplaced with respect to each other.

Design Rule Checks

EasySim will allow errors in circuit design to be made and does not apply any form of design rule checking at the editing stage.

One symptom of design errors is that EasySim will not simulate correctly when two or more outputs are joined (or shorted) together. What will actually happen is that one of the two outputs will be ignored.
The reason for this is the way that EasySim constructs the electrical network before performing any simulation.

Basically EasySim collects together all outputs in one place and all inputs and wires in another. As the network is built EasySim looks at the first output that it finds and then traces the circuit from that point, removing wires from the 'free list' and binding them to the associated output. This means that where two outputs are connected together the second output to be processed will no longer be able to find a wire to connect to, even though the screen editor suggests otherwise.

Likewise two inputs connected to each other will not be processed as they have no associated output node from which any network including them can be built.

In this case the inputs remain unconnected and the wire joining them remains unassigned.

**Open Inputs**

It is good practice to connect otherwise unused inputs. EasySim simplifies the situation of any unconnected inputs. These will all default to logic low.

This cannot be assumed to be the case in an actual electronic circuit.

The fixed logic level sources are supplied so that any uncommitted inputs may be tied to a known level.

For a logic high level select the Logic 1 option from the Sources menu or select the button of the toolbox.

For a logic low level select the Logic 0 option from the Sources menu or select the button of the toolbox.
CHAPTER 6

*EasySim* Logic Blocks

This chapter describes the various types of logic blocks available within *EasySim*. Basically these may be split into 3 types:

1. Output only devices. These are the logic sources.
2. Input and output devices. These are the logic gates that contain the varying functionality dependant on the type of gate being emulated.
3. Input only devices. These are the visual displays.

Logic Sources

*EasySim* supplies three different logic sources. Two of these supply a fixed level at either a logic low (0) or a logic high (1).

The logic sources are accessible from either the Sources menu or from the toolbox.

Selecting any of the logic sources options will change the cursor shape to match that of the object selected. This cursor may now be moved around the screen by use of the mouse. Once in the required position the selected logic source may be 'placed' by clicking the left button on the mouse. The cursor will change back to its normal state at this time, preventing accidental repetitive placing of the same object in the same place. Subsequent logic sources will have to be re-selected should multiple sources be required.

Should the orientation of any logic source be not as required, select the button of the toolbox, move the cursor over the logic source and click the left mouse button. This procedure will horizontally flip the logic source, or indeed any rotatable item, under the mouse.
Logic 0 Source

Select this item with either the logic 0 button of the toolbox or by selecting the Logic 0 option from the Sources menu.

The logic 0 source provides a constant logic 0, or low, level at its output pin. The level only becomes valid once the circuit is powered up.

This item is useful for tying otherwise unused inputs to a known logic level, or for providing a specific logic level at a particular point in the circuit.

The active contact area for a logic 0 source is anywhere on the horizontal section projecting from the right hand side of the main body as shown here.

To make a correct connection run a wire horizontally either to or on to this point.

Logic 1 Source

Select this item with either the logic 1 button of the toolbox or by selecting the Logic 1 option from the Sources menu.

The logic 1 source provides a constant logic 1, or high, level at its output pin. The level only becomes valid once the circuit is powered up.

This item is useful for tying otherwise unused inputs to a known logic level, or for providing a specific logic level at a particular point in the circuit.

The active contact area for a logic 1 source is anywhere on the horizontal section projecting from the right hand side of main body as shown here.

To make a correct connection run a wire horizontally either to or on to this point.

Level Switch

Select this item with either the switch button of the toolbox or by selecting the Switch option from the Sources menu.
This item becomes active whilst EasySim is in its 'powered up' state. It is the switch that allows simulation to be performed by introducing changes in logic level to an otherwise steady state circuit.

The output will toggle from a 0 to a 1 or from a 1 to a 0, depending on its initial state, when the left mouse button is clicked whilst the cursor is over the switch.

These changes of level will then be propagated through the entire circuit. If logic tracing is selected the changes are visible as the logic levels alter on connecting wires.

The active contact area for a switch is anywhere on the horizontal section projecting from the right hand side of the switch past the 'bump' as shown here.

To make a correct connection run a wire horizontally either to or on to this point.

### Logic Gates

EasySim provides a good selection of common gates. These include inverters, exclusive or, exclusive nor, or, nor, and and nand gates, along with 'D' type and JK flip flops.

Where it is appropriate for gates to have a variable number of inputs these have been provided in their 2, 3 and 4 input variations.

All gates may be selected from either the toolbox, the Gates menu or a further sub-menu from within the Gates menu.
Select this item with either the INVERTER button of the toolbox or by selecting the Inverter option from the Gates menu.

The INVERTER is a gate with a single input and one output. The output level is always the inverse of the input level.

<table>
<thead>
<tr>
<th>A</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for an INVERTER.

The Exclusive Or

Select this item with either the EXCLUSIVE OR button of the toolbox or by selecting the Exclusive Or option from the Gates menu.

The EXCLUSIVE OR gate has two inputs and one output. The output is at a logic high when either one of the two inputs is high. If both inputs are either at a high or a low level the output will be a logic low.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for an EXCLUSIVE OR gate.

The Exclusive Nor

Select this item with either the EXCLUSIVE NOR button of the toolbox or by selecting the Exclusive Nor option from the Gates menu.

The EXCLUSIVE NOR gate has two inputs and one output and is the reverse in operation to the EXCLUSIVE OR gate. The output is at a logic low when either one of the two inputs is high. If both inputs are either at a high or a low level the output will be a logic high.
**The Or Gate**

*EasySim* provides or gates in a choice of 2, 3 or 4 input devices. These may be selected either directly from the appropriate toolbox button or by a sub-menu invoked by the Or Gates option of the Gates menu.

- **2 Input Or**
- **3 Input Or**
- **4 Input Or**

The output of an OR gate is high if any of its inputs are at a high level. If all inputs are at a low level then the output will also be low.

The 2 input OR gate may be selected by the button of the toolbox or by the 2 Input Or sub-menu selection from the Or Gates option of the Gates menu.

If either of the 2 inputs is at a logic high level then the output will be at a logic high. If, however, both inputs are at a low level then the output will also be low.

*Truth Table for a 2 Input OR gate.*

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

The 3 input OR gate may be selected by the button of the toolbox or by the 3 Input Or sub-menu selection from the Or Gates option of the Gates menu.

If any of the 3 inputs are at a logic high level then the output will be at a logic high. If, however, all inputs are at a low level then the output will also be low.

*Truth Table for a 2 Input OR gate.*

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>
The 4 Input OR Gate

The 4 input OR gate may be selected by the button of the toolbox or by the 4 Input Or sub-menu selection from the Or Gates option of the Gates menu.

If any of the 4 inputs are at a logic high level then the output will be at a logic high. If, however, all inputs are at a low level then the output will also be low.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>1</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>X</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1</td>
</tr>
</tbody>
</table>

Truth Table for a 4 Input OR gate.

The Nor Gate

EasySim provides NOR gates in a choice of 2, 3 or 4 input devices. These may be selected either directly from the appropriate toolbox button or by a sub-menu invoked by the Nor Gates option of the Gates menu.

The output of a NOR gate is low if any of its inputs are at a high level. If all inputs are at a low level then the output will be at a logic high.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>X</td>
</tr>
<tr>
<td>1</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Truth Table for a 2 Input NOR gate.

The 2 input NOR gate may be selected by the button of the toolbox or by the 2 Input Nor sub-menu selection from the Nor Gates option of the Gates menu.

If either of the 2 inputs is at a logic high level then the output will be at a logic low. If, however, both inputs are at a low level then the output will be at a logic high.
The 3 Input Nor Gate

Symbol

The 3 input NOR gate may be selected by the button of the toolbox or by the 3 Input Nor sub-menu selection from the Nor Gates option of the Gates menu.

If any of the 3 inputs are at a logic high level then the output will be at a logic low. If, however, all inputs are at a low level then the output will be at a logic high.

Truth Table for a 3 Input NOR gate.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>X</td>
<td>X</td>
<td>0</td>
</tr>
</tbody>
</table>

The 4 Input Nor Gate

Symbol

The 4 input nor gate may be selected by the button of the toolbox or by the 4 Input Nor sub-menu selection from the Nor Gates option of the Gates menu.

If any of the 4 inputs are at a logic high level then the output will be at a logic low. If, however, all inputs are at a low level then the output will be at a logic high.

Truth Table for a 4 Input NOR gate.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>1</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>X</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>0</td>
</tr>
</tbody>
</table>

The And Gate
EasySim provides AND gates in a choice of 2, 3 or 4 input devices. These may be selected either directly from the appropriate toolbox button or by a sub-menu invoked by the And Gates option of the Gates menu.

**2 Input And**

**3 Input And**

**4 Input And**

The output of an AND gate is high only if all of its inputs are at a high level. If any inputs are at a low level then the output will also be low.

The 2 input AND gate may be selected by the button of the toolbox or by the 2 Input And sub-menu selection from the And Gates option of the Gates menu.

If both of the 2 inputs are at a logic high level then the output will be at a logic high. If, however, either input is at a low level then the output will also be low.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Truth Table for a 2 Input AND gate.

The 3 input AND gate may be selected by the button of the toolbox or by the 3 Input And sub-menu selection from the And Gates option of the Gates menu.

If all of the 3 inputs are at a logic high level then the output will be at a logic high. If, however, any inputs are at a low level then the output will also be low.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>X</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Truth Table for a 3 Input AND gate.
The 4 input AND gate may be selected by the button of the toolbox or by the 4 Input And sub-menu selection from the And Gates option of the Gates menu.

If all of the 4 inputs are at a logic high level then the output will be at a logic high. If, however, any inputs are at a low level then the output will also be low.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>0</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>X</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Truth Table for a 4 Input AND gate.

The Nand Gate

EasySim provides nand gates in a choice of 2, 3 or 4 input devices. These may be selected either directly from the appropriate toolbox button or by a sub-menu invoked by the Nand Gates option of the Gates menu.

The output of a NAND gate is low if all of its inputs are at a high level. If any input is at a low level then the output will be at a logic high.

The 2 input NAND gate may be selected by the button of the toolbox or by the 2 Input Nand sub-menu selection from the Nand Gates option of the Gates menu.

If both of the 2 inputs are at a logic high level then the output will be at a logic low. If, however, either input is at a low level then the output will be at a logic high.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for a 2 Input NAND gate.
The 3 input NAND gate may be selected by the button of the toolbox or by the 3 Input Nand sub-menu selection from the Nand Gates option of the Gates menu.

If all of the 3 inputs are at a logic high level then the output will be at a logic low. If, however, any input is at a low level then the output will be at a logic high.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>X</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for a 3 Input NAND gate.

The 4 input NAND gate may be selected by the button of the toolbox or by the 4 Input Nand sub-menu selection from the Nand Gates option of the Gates menu.

If all of the 4 inputs are at a logic high level then the output will be at a logic low. If, however, any input is at a low level then the output will be at a logic high.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>0</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>X</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for a 4 Input NAND gate.

The D Type Flip-Flop

Select this item with either the D TYPE FLIP-FLOP button or by selecting the D Flip Flop option from the Gates menu.

The D TYPE FLIP FLOP, as provided in EasySim, has three inputs and two outputs.

Its operation is different from a normal gate insomuch as it is an edge triggered device. In this case the logic level on the D input is transferred to the Q output on the rising edge of a signal applied to the C, or clock input. Changes of level on the D input whilst the C input is either high or low will have no effect.
The second, or $\bar{Q}$, output is always the inverse of the Q output. This means that when the Q output is at a logic high the $\bar{Q}$ output will be at a logic low and vice versa.

A third input on the D TYPE FLIP-FLOP is the 'R' or reset input. In EasySim this is an asynchronous reset. Applying a logic high to this input will cause the Q output to go to a logic low and the $\bar{Q}$ output to go high. This state will remain so long as the reset input remains at a high level and will only change once the reset input goes to a low level and a rising edge on the clock input occurs whilst a high level exists on the D input.

<table>
<thead>
<tr>
<th>R</th>
<th>D</th>
<th>C</th>
<th>Q</th>
<th>$\bar{Q}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>X</td>
<td>X</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>↑</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>↑</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for a D TYPE FLIP-FLOP.

The JK Flip-Flop

Select this item with either the JK FLIP-FLOP button or by selecting the JK Flip Flop option from the Gates menu.

The JK FLIP-FLOP, as provided in EasySim has three inputs and two outputs. In operation it is quite different from the D TYPE FLIP-FLOP described above.

The JK FLIP-FLOP derives its name from the two programming, or J and K, inputs. These inputs allow four modes of operation to be performed.

Like the D TYPE FLIP-FLOP this device also has a 'C' or clock input at which it is low to high logic level transitions control the operation of the JK flip-flop.

Also like the D TYPE the JK FLIP FLOP has Q and $\bar{Q}$ outputs, with the $\bar{Q}$ output always being the inverse of the Q output.

The four modes of operation of the JK FLIP-FLOP are as follows:

1. The hold mode. In this mode both the J and the K inputs are set to a logic low level. When a clock pulse is applied the J and K outputs will not alter from their previous value.

2. The set mode. In this mode the J input is set to a high level and the K input to a low level. When a clock pulse is applied the Q output will go high and the $\bar{Q}$ output low.
3. The reset mode. In this mode the J input is set to a low level and the K input to a high level. When a clock pulse is applied the Q output will go low and the $\overline{Q}$ output high.

4. The toggle mode. In this mode both the J and the K inputs are set to a logic high level. When a clock pulse is applied both outputs will change their values, i.e. if the Q output was low it will change to a high level and if the Q output was high it will change to a low level.

<table>
<thead>
<tr>
<th>Mode</th>
<th>J</th>
<th>K</th>
<th>$Q_n$</th>
<th>$Q_{n+1}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hold</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>&quot;</td>
<td></td>
<td></td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Reset</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>&quot;</td>
<td></td>
<td></td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Set</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>&quot;</td>
<td></td>
<td></td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Toggle</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>&quot;</td>
<td></td>
<td></td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Truth Table for a JK FLIP-FLOP where $Q_n$ is the Q output before the clock pulse and $Q_{n+1}$ the output after the clock pulse.
Logic Displays

*EasySim* supplies two types of visual indicators or displays. These are the 7 Segment Display and the Lamp.

The indications given by these displays will change depending on the logic level applied at their input pin(s).

The displays may be selected from either the toolbox or from within the Displays menu.

### The Lamp

Select this item with either the lamp button of the tool box or by selecting the Lamp option from the Displays menu.

The lamp will become active when *EasySim* is in its powered up state. During this time a logic level on it's input pin will be reflected in the colour of the lamp. With a logic 1, or high, level on its input the lamp will glow yellow. When a logic 0, or low, level is applied, however, the lamp will revert to a dark grey colour.

### The 7 Segment Display

Select this item with either the 7 segment button of the tool box or by selecting the Lamp option from the Displays menu.

The 7 segment display gives a visual representation according to the binary value of the logic levels that exist on its four inputs.

The display gives a readout in hexadecimal notation (a base 16 count that goes from 0 to 9 and then from A to F) in order to display all 16 possible binary values that may exist at it's input. It derives it's name from the fact that all 16 hexadecimal digits are derived by highlighting one of the seven segments that make up the display.
<table>
<thead>
<tr>
<th>D</th>
<th>C</th>
<th>B</th>
<th>A</th>
<th>Digit</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>2</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>4</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>5</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>6</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>7</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>8</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>9</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>A</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>b</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>c</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>d</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>E</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>F</td>
</tr>
</tbody>
</table>

Truth table for a 7 segment display.
CHAPTER 7

*EasySim* Display Options

**Grid Display**

<table>
<thead>
<tr>
<th>Grid</th>
<th>Logic Trace</th>
<th>Redraw</th>
</tr>
</thead>
</table>

The grid display option is only available from within the Options menu.
Selecting this option will place a background grid in the *EasySim* work area. This grid is on a 10 pixel spacing and will act as an aid to placing items on the screen.

To remove the grid once placed just reselect the option once more.

**Logic Tracing**

<table>
<thead>
<tr>
<th>Grid</th>
<th>Logic Trace</th>
<th>Redraw</th>
</tr>
</thead>
</table>

The logic tracing option is only available from within the Options menu.
Selecting this option will turn on the wire highlighting mode of *EasySim*. When this is active, and *EasySim* is in its powered up mode, all wires carrying a logic 1, or high, level will be highlighted with respect to those that are carrying a logic 0, or low, level.

To turn off logic tracing, once enabled, just reselect the option once more.

**Redraw Facility**

<table>
<thead>
<tr>
<th>Grid</th>
<th>Logic Trace</th>
<th>Redraw</th>
</tr>
</thead>
</table>

The redraw option is only available from within the Options menu.
Selecting this option will cause the screen to be re-drawn. This will help to remove any fragments or bits of items left on the screen after items have been deleted.
Sample Circuits

This section looks at some of the sample circuit files included with the EasySim package.

D Type Flip-Flop

The following circuit is that of the internals of a D type flip-flop. This circuit is supplied pre-drawn as "DTYPE.SIM" on the EasySim distribution disk. Note that the reset input is not included in this circuit.

Load up this circuit with EasySim and experiment with the clock and data (D) inputs.

You will find that any level on the D input is clocked through to the Q output as the clock input is changed from a 0 to a 1.

JK Flip-Flop

The following circuit is that of the internals of a master-slave JK flip-flop. This circuit is supplied pre-drawn as "MSJK.SIM" on the EasySim distribution disk.
Another example of a basic JK flip-flop exists in the file "JK.SIM". See if you can determine any differences in operation between the two types of JK flip-flops.

Once again load up this circuit with EasySim and experiment with the four modes of operation as detailed in the JK flip-flop section of this manual.

Simulated Dice

This last circuit is the basis for an exercise in design. The basic lamp setup for an electronic dice is supplied in the "DICE.SIM" circuit file. Using this as a guide, design a counter that will correctly sequence the lamps from 1 to 6.

First experiment with the four toggle switches to get a 'feel' for the type of logic levels that you will have to provide in order to ensure correct sequencing of the lamps.

Synchronous Counter
The following circuit is that of a 4 bit synchronous counter, with a few extra additions. This circuit is supplied pre-drawn as "COUNT16.SIM" on the EasySim distribution disk.

Basically this circuit is a counter with a display attached to it. As the clock pulses arrive so the count, and the displayed value, will increment. Once the count reaches 15 (or F in hexadecimal) all four inputs to the AND gate will be at a high level. This will mean that the output of the AND gate will go to a high level and cause the lamp to light.

The type of counter shown is called synchronous because all outputs change at the same time. This is at variance with a ripple counter whose count depends on the output of one stage clocking the next. This causes the count to 'ripple through' the counter, this will mean that at some time after the clock pulse the values at the counter outputs will not be as expected. For an exercise construct a ripple counter using D type flip-flops and examine its operation closely with logic tracing enabled.
INDEX

A
Applying Power, 18

C
Circuit Files
  Default Suffix, 8

D
Deleting Items, 15
Design Rule Checking, 20
Device Orientation, 16
Displays
  7 Segment, 35
  Lamp, 35

E
EasySim
  Empty Window, 5
  Exiting, 5
  Getting Started, 3
  Icon, 4
  Main Features, 1
  Starting, 4
  Title Bar, 8
  Windows Group, 4
Edit
  Delete, 15
  Move, 16
  Rotate, 16
Electrical Network Construction, 21

F
Files
  Opening, 8
  Printing, 11
  Renaming, 10
  Saving, 10

G
Gates

And, 30
D Type Flip-Flop, 32
Exclusive Nor, 26
Exclusive Or, 26
Inverter, 26
JK Flip-Flop, 33
Nand, 31
Nor, 28
Or, 27
Good Connections
  Importance of, 17
Grid
  On-screen, 37
  Snap To, 20

H
Hardware
  Minimum Requirements, 2
Help
  Context Sensitive, 6
  Online, 6

I
Inputs
  Uncommitted, 21
Installation
  Aborting, 4
  Dialogue Box, 4
  Directory Selection, 3
    from DOS, 3
    Windows, 3

J
Junctions
  Using, 7, 20

L
Logic Sources
  0 level, 24
  1 level, 24
  Switch, 24
Logic Tracing
Selecting, 37
When to use, 18
M
Menu
Displays, 35, 37
Edit, 15
File, 8
Gates, 25
Power, 18
Routing, 19
Sources, 23
Mouse
Button Usage, 7
Moving Items, 16
O
Outputs
Shorted, 20
P
Power Button, 18
Power On Mode, 9
Printer Setup, 12
R
Redraw, 15
Rotating Items, 16
S
Sample Circuits
D Type Flip-Flop, 39
Dice Simulation, 40
JK Flip-Flop, 39
Synchronous Counter, 41
Screen
Redrawing, 37
When to Redraw, 15
Screen Size, 11
Snap to Grid, 20
Support
Technical, 2
T
44

Toolbox, 7
Truth Table
2 Input And, 30
2 Input Nand, 31
2 Input Nor, 29
2 Input Or, 27
3 Input And, 30
3 Input Nand, 32
3 Input Nor, 29
3 Input Or, 28
4 Input And, 31
4 Input Nand, 32
4 Input Nor, 29
4 Input Or, 28
7 Segment Display, 36
D Type Flip-Flop, 33
Exclusive Nor, 27
Exclusive Or, 26
Inverter, 26
JK Flip-Flop, 34

Unstable Circuit Indication, 18
UNTITLED.SIM, 8

Wires
Connecting, 7, 20
Crossing, 17, 20
Highlighting, 17
Placing, 19
Rubber Banding, 19
Segments, 19

Wiring
Connection overlap, 20
Contact Zone, 7, 20